Arquitetura de Computadores - Exercicios - Ciencia da Computacao, Notas de estudo de Ciência da Computação. Centro Federal de Educação Tecnológico (CEFET-PA)
Alfredo_88
Alfredo_885 de Março de 2013

Arquitetura de Computadores - Exercicios - Ciencia da Computacao, Notas de estudo de Ciência da Computação. Centro Federal de Educação Tecnológico (CEFET-PA)

PDF (289.1 KB)
10 páginas
5Números de download
1000+Número de visitas
Descrição
Apostilas e exercicios de Ciencia da Computação sobre o estudo da arquitetura de computadores, perguntas e respostas.
20pontos
Pontos de download necessários para baixar
este documento
baixar o documento
Pré-visualização3 páginas / 10
Esta é apenas uma pré-visualização
Consulte e baixe o documento completo
Esta é apenas uma pré-visualização
Consulte e baixe o documento completo
Pré-visualização finalizada
Consulte e baixe o documento completo
Esta é apenas uma pré-visualização
Consulte e baixe o documento completo
Esta é apenas uma pré-visualização
Consulte e baixe o documento completo
Pré-visualização finalizada
Consulte e baixe o documento completo

1) Analise as seguintes afirmações relacionadas a conceitos básicos de arquitetura de computadores classificando-as como verdadeira ou falsa e justificando cada uma delas.

I. Nos computadores mais modernos, a transferência de informações entre o disco rígido e a memória RAM é controlada pelo processador, fazendo com que o sistema fique mais rápido.

(FALSA)

I- A memória é responsável em geral, a ponte norte que tem o controlador de memória, o controlador está realmente no processador, a AMD utiliza em seus processadores de soquetes 754,939 e 940, o Hyper Transport para ter um ganho de velocidade para acessar algum dado na memória. O que controla o HD (para qualquer HD Paralelo ATA ou Serial ATA, que são DMA, e outros do tipo PIO, há também os HDs SCSI, estes geralmente requerem uma placa ou chip específico que não fica no processador) é a ponte sul, especificamente controlador DMA ou PIO.

II. O BIOS (Basic Input Output System - Sistema Básico de Entrada e Saída) define, para o processador, como operar com os dispositivos básicos, como o vídeo em modo texto, o disco rígido e a unidade de disquete. Este programa fica gravado na memória RAM do computador.

(FALSA)

II - O processador não é definido pela BIOS para operar os dispositivos exatamente, ela faz uma checagem e envia ao processador informações de boot e aplicativo (driver) que deve ser usado é carregado do HD, a citada operação é feita através de softwares e hardwares específicos, o controlador IDE, ou DirectX, seria um bom exemplo...

III. USB (Universal Serial Bus) é um tipo de conexão que permite conectar de forma prática e rápida, sem a necessidade de desligar o computador, diversos tipos de periféricos, como impressoras, mouse, câmera e modem.

(VERDADEIRA)

III- A universal serial bus é uma porta de entrada de dados que como objetivo conectar dispositivos (plug and play) sem que se desligue o micro.

docsity.com

IV. A Memória USB Flash Drive, conhecida em alguns casos como de pendrive, é um dispositivo de armazenamento constituído por uma memória flash e um adaptador USB para interface com o computador. A capacidade de armazenamento destes dispositivos já ultrapassa 1 GByte.

(FALSA)

IV - O pendrive se constitui de memória flash e um dispositivo USB, e hoje pode-se encontrar esse tipo de memória quase que com a mesma capacidade de um hard disk, 20 gb, 40 gb...

2) O BIOS é um CHIP que tem instruções gravadas de fábrica para realizar durante a inicialização do computador, o tipo de memória que armazena os dados do BIOS é:

a) RAM b) SRAM c) CACHE d) ROM

3) A respeito das configurações de computador mostradas acima e dos principais conceitos de hardware, comente os itens seguintes:

a) Apesar da vantagem da mobilidade apresentada pelo computador da configuração 2 em relação ao computador da configuração 1, é correto afirmar que o primeiro computador apresenta características que o tornam mais indicado para certas atividades que porventura requeiram maior poder de processamento e espaço em memória e maior capacidade de armazenamento em disco.

VERDADEIRO:

O computador 1 apresenta um processador mais potente (Pentium 4 1.5GHz) em relação ao computador 2 (Celeron 1Ghz). Além que apresenta uma maior capacidade de memória RAM e do Disco Rígido (256MB e 40GB) contra apenas os 128MB e 20GB do computador 2.

b) As duas configurações apresentadas acima possuem alguns itens semelhantes entre si, como a presença de uma placa de rede de mesma velocidade em ambos os computadores, além de possuírem o mesmo sistema operacional. Também é possível detectar uma unidade leitora de DVD nos dois equipamentos.

VERDADEIRO:

Placa de Rede 10/100 e Porta Ethernet 10/100 são a mesma coisa: Placa de Rede pode trabalhar com taxas de transferência de 10Mbps e 100Mbps. O sistema operacional é o Windows XP Home e ambos possuem Drive de DVD-ROM.

docsity.com

c) Após a aquisição de qualquer um dos dois computadores apresentados acima, não há a necessidade de instalação de nenhum programa ou equipamento extra, pois ambas as configurações apresentam dispositivos capazes de efetuar conexões em redes Dial-up e em estruturas de LAN e os pacotes de programas que os acompanham atendem completamente os requisitos exigidos para a aquisição.

FALSO:

Esta faltando softwares que permitam a edição deste tipo de documento como o Word e o Excel, vendidos no mesmo pacote de programas (O Microsoft Office), que não é oferecido em nenhuma das duas ofertas. Sendo útil a informação que os computadores vão ser adquiridos para acesso à Internet e Intranet, além de edição de documentos de texto e planilhas eletrônicas, portanto

d) Para acelerar o processo de acesso à Internet por meio de uma rede Dial-up (linha telefônica), um usuário poderia dispensar o Modem, equipamento que atinge, no máximo, uma taxa de transferência de 56 Kilobits por segundo, e utilizar, em seu lugar, Modems mais novos, como um Cable Modem, que pode atingir taxas de transferência da ordem de 10 Gigabits por segundo.

FALSO:

As conexões em forma de linhas telefônicas convencionais só poderão ser efeutadas perante o uso do Modem. Sendo que, a taxa de transferência do Cable Modem (equipamento usado para conexão a cabo com a Internet) é na ordem de 64Kbps a 5Mbps. Enfim, 10 Gbps é IMPOSSÍVEL para usuários domésticos.

e) Para que o computador tenha sua capacidade de processamento aumentada, alguns usuários mais experientes realizam um processo chamado Overclocking, que consiste em alterar algumas configurações técnicas na Placa mãe do computador para que o processador trabalhe em freqüências superiores à original de fábrica.

VERDADEIRO:

Possível alterar algumas configurações na parte física do computador para que este trabalhe em freqüências maiores. Este processo não é simples, e chama-se Overclocking.

O movimento do software livre ganhou notoriedade nos últimos anos. Esse modo de produção de software tem resultado em produtos de excelente qualidade e grande penetração em certos nichos do mercado mundial de software. A característica mais importante do software livre é a liberdade de uso, cópia, modificação e redistribuição. Esta liberdade é conferida pelos autores do programa e é efetivada através da distribuição do código-fonte dos programas, o que os transforma em bens públicos, disponíveis para utilização por toda a comunidade e da maneira que seja mais conveniente a cada indivíduo. A liberdade para usar, copiar, modificar e

docsity.com

redistribuir software livre lhe confere uma série enorme de vantagens sobre o software proprietário.

4) A partir do texto acima, julgue os itens abaixo.

1. O autor tem uma perspectiva enviesada do software livre, na medida em que trata apenas dos aspectos positivos do produto, sem abordar os pontos negativos.

FALSO

2. O software livre tem, entre suas vantagens, a possibilidade de ser aperfeiçoado por qualquer pessoa que possua conhecimentos e idéias que agregam valor ao programa.

VERDADEIRO

3. A partir do momento em que é alterado e melhorado, o software livre pode ser comercializado e ter o código-fonte fechado.

FALSO

4. O software livre tem como vantagem adicional a garantia, por parte de seus autores, em fornecer suporte a todos os usuários que necessitem de auxílio.

FALSO

5. Software livre é o mesmo que software aberto, e o seu objetivo é popularizar o uso do computador promovendo a inclusão digital.

FALSO

6. Todo software livre deve ser desenvolvido para uso por pessoa física em ambiente com sistema operacional da família Linux, devendo haver restrições de uso a serem impostas por fornecedor no caso de outros sistemas operacionais.

docsity.com

FALSO

7. O código-fonte de um software livre pode ser adaptado ou aperfeiçoado pelo usuário, para necessidades próprias, e o resultado de aperfeiçoamentos desse software pode ser liberado e redistribuído para outros usuários, sem necessidade de permissão do fornecedor do código original.

VERDADEIRO

8. Toda licença de software livre deve estabelecer a liberdade de que esse software seja, a qualquer momento, convertido em software proprietário e, a partir desse momento, passem a ser respeitados os direitos de propriedade intelectual do código-fonte do software convertido.

FALSO

9. Quando a licença de um software livre contém cláusula denominada copyleft, significa que esse software, além de livre, é também de domínio público e, dessa forma, empresas interessadas em comercializar versões não gratuitas do referido software poderão fazê-lo, desde que não haja alterações nas funcionalidades originais do software.

FALSO

10. Um software livre é considerado software de código aberto quando o seu código-fonte está disponível em sítio da Internet com designação .org, podendo, assim, ser continuamente atualizado, aperfeiçoado e estendido às necessidades dos usuários, que, para executá-lo, devem compilá-lo em seus computadores pessoais. Essa característica garante a superioridade do software livre em face dos seus concorrentes comerciais proprietários.

FALSO

11. No âmbito do governo federal tem-se dado preferência aos produtos comerciais em lugar de software livre.

VERDADEIRO

docsity.com

12. Freewares são softwares sem qualquer proteção de direitos autorais, que podem ser utilizados sem restrição de uso e de código fonte.

FALSO

a. O negrito tem a função de escurecer o texto.

b. Cor da fonte faz alterações na cor do texto.

c. Os marcadores diferencia o estilo do texto com diversos modelos de marcadores.

d. As bordas inferiores servem para aplicar as células e selecionar.

e.

6) Coloque V (verdadeiro) ou F (falso). Justifique as alternativas que você julgar falsas.

a. ( V) Quando inserimos uma figura, podemos formatá-la como desejamos: podemos mudar contraste, brilho, mudar seu posicionamento em relação à página;

b. (V) Podemos colocar as iniciais de um texto em formato Capitular;

c. ( V) O Microsoft Office Word 2007 possui um gerenciador de clip-art;

d. ( V) Podemos ativar e desativar os marcadores a qualquer momento: basta dar um clique no botão marcadores ou no botão numeração que ficam na guia início;

e. ( V) O Word 2007 traz as ferramentas organizadas em guias;

f. ( F) A opção para dividir o texto em colunas encontra-se na guia Inserir.

(encontra-se em Layout da página colunas)

7) Elaborar a planilha abaixo, fazendo-se o que se pede:

Empresa Nacional S/A | | | | | | |

| | | | | | | | |

Código | Produto | Jan | Fev | Mar | Total 1º Trim. | Máximo | Mínimo | Média |

docsity.com

1 | Porca | 4.500,00 | 5.040,00 | 5.696,00 | =SOMA(C2:E2) | =MAXIMO(C2:E2) | =MINIMO(C2:E2) | =MEDIA(C2:E2) |

2 | Parafuso | 6.250,00 | 7.000,00 | 7.910,00 | =SOMA(C3:E3) | =MAXIMO(C3:E3) | =MINIMO(C3:E3) | =MEDIA(C3:E3) |

3 | Arruela | 3.300,00 | 3.696,00 | 4.176,00 | =SOMA(C4:E4) | =MAXIMO(C4:E4) | =MINIMO(C4:E4) | =MEDIA(C4:E4) |

4 | Prego | 8.000,00 | 8.690,00 | 10.125,00 | =SOMA(C5:E5) | =MAXIMO(C5:E5) | =MINIMO(C5:E5) | =MEDIA(C5:E5) |

5 | Alicate | 4.557,00 | 5.104,00 | 5.676,00 | =SOMA(C6:E6) | =MAXIMO(C6:E6) | =MINIMO(C6:E6) | =MEDIA(C6:E6) |

6 | Martelo | 3.260,00 | 3.640,00 | 4.113,00 | =SOMA(C2:E7) | =MAXIMO(C7:E7) | =MINIMO(C7:E7) | =MEDIA(C7:E7) |

| | | | | | | | |

Totais | | =SOMA(C2:C7) | =SOMA(D2:D7) | =SOMA(E2:E7) | =SOMA(E2:E7) | =SOMA(F2:F7) | =SOMA(G2:G7) | =SOMA(H2:H7) |

| | | | | | | | |

Código | Produto | Abr | Mai | Jun | Total 2º Trim. | Máximo | Mínimo | Média |

1 | Porca | 6.265,00 | 6.954,00 | 7.858,00 | =SOMA(C15:E15) | =MAXIMO(C15:E15) | =MINIMO(C15:E15) | =MEDIA(C15:E152) |

2 | Parafuso | 8.701,00 | 9.658,00 | 10.197,00 | =SOMA(C16:E16) | =MAXIMO(C16:E16) | =MINIMO(C16:E16) | =MEDIA(C16:E16) |

3 | Arruela | 4.569,00 | 5.099,00 | 5.769,00 | =SOMA(C17:E17) | =MAXIMO(C17:E17) | =MINIMO(C17:E17) | =MEDIA(C17:E17) |

4 | Prego | 12.341,00 | 12.365,00 | 13.969,00 | =SOMA(C18:E18) | =MAXIMO(C18:E18) | =MINIMO(C18:E18) | =MEDIA(C18:E18) |

5 | Alicate | 6.344,00 | 7.042,00 | 7.957,00 | =SOMA(C19:E19) | =MAXIMO(C19:E19) | =MINIMO(C19:E19) | =MEDIA(C19:E19) |

6 | Martelo | 4.525,00 | 5.022,00 | 5.671,00 | =SOMA(C20:E20) | =MAXIMO(C20:207) | =MINIMO(C20:E10) | =MEDIA(C20:E20) |

| | | | | | | | |

docsity.com

Totais | | =SOMA(C15:C20) | =SOMA(D15:D20) | =SOMA(E15:E20) | =SOMA(F15:F20) | =SOMA(G15:G20) | =SOMA(H15:H20) | =SOMA(I15:I20) |

| | | | | | | | |

Total do Semestre | =SOMA(C12+C22) | =SOMA(D12+D22) | =SOMA(E12+E22) | =SOMA(F12+F22) | =SOMA(G12+G22) | =SOMA(H12+H22) | =SOMA(I12+I22) |

FÓRMULAS:

1ª Tabela:

Total 1º Trimestre: soma das vendas dos meses de Jan / Fev / Mar.

Máximo: calcular o maior valor entre os meses de Jan / Fev / Mar.

Mínimo: calcular o menor valor entre os meses de Jan / Fev / Mar.

Média: calcular a média dos valores entre os meses de Jan / Fev / Mar.

2ª Tabela:

Total 2º Trimestre: soma das vendas dos meses de Abr / Mai / Jun.

Máximo: calcular o maior valor entre os meses de Abr / Mai / Jun.

Mínimo: calcular o menor valor entre os meses de Abr / Mai / Jun.

Média: calcular a média dos valores entre os meses de Abr / Mai / Jun.

Totais: soma das colunas de cada mês (1ª e 2ª tabela).

Total do Semestre: soma dos totais de cada trimestre.

8) Elaborar a planilha abaixo, fazendo-se o que se pede:

| | Projeção para o ano de 2003 | | |

| | | | | |

docsity.com

Receita bruta | Jan-Mar | Abr-Jun | Jul-Set | Out-Dez | Total do Ano |

| 140.000,00 | 185.000,00 | 204.100,00 | 240.000,00 | =SOMA(B5:E5) |

| | | | | |

Despesa Líquida | Jan-Mar | Abr-Jun | Jul-Set | Out-Dez | Total do Ano |

Salários | 20.000,00 | 26.000,00 | 33.800,00 | 43.940,00 | =SOMA(B8:E8) |

Juros | 20.000,00 | 15.600,00 | 20.280,00 | 26.364,00 | |

Aluguel | 12.000,00 | 20.930,00 | 27.209,00 | 35.371,70 | |

Propaganda | 16.100,00 | 28.870,00 | 33.631,00 | 43.720,30 | |

Suprimentos | 19.900,00 | 39.000,00 | 50.700,00 | 65.910,00 | |

Diversos | 25.000,00 | 32.500,00 | 42.250,00 | 54.925,00 | |

| | | | | |

Total do Trim. | | | | | |

Receita líquida | | | | | |

Situação | | | | | |

| | Valor Acumulado do ano de despesas | |

FÓRMULAS:

Total do Ano Receita Bruta: Soma das receitas anuais.

Total do Ano Despesa Líquida: Soma das despesas anuais.

Total do Trimestre: Soma das despesas trimestrais.

Receita Líquida: Receita Bruta menos Total do Trimestre.

docsity.com

Valor Acumulado do ano de despesas: Soma do Total do Ano de Despesas

Situação: Se Receita Líquida for menor que R$ 1.000,00, "Prejuízo Total";

Se Receita Líquida for menor que R$ 5.000,00, "Lucro Médio";

Se Receita Líquida for maior que R$ 5.000,00, "Lucro Total'.

Qual seria uma fórmula, utilizando a função SE para a situação descrita acima?

=SE(B16<1000;"Prejuízo Total";SE(B16<=5000;"Lucro Médio";SE(B16>5000;"Lucro Total")))

9) Acionar o menu “Arquivo > Novo “ e clicar na opção “Planilha “, abrirá o aplicativo “Calc “. Clicar na opção “ Banco de dados “ abrirá o “Base “. Clicar na opção “Impress “ permitirá:

a. Criar uma apresentação de slides.

b. Criar uma planilha eletrônica.

c. Criar fórmulas matemáticas.

d. Imprimir o documento atual.

e. Visualizar a impressão do documento atual.

docsity.com

comentários (0)
Até o momento nenhum comentário
Seja o primeiro a comentar!
Esta é apenas uma pré-visualização
Consulte e baixe o documento completo
Docsity is not optimized for the browser you're using. In order to have a better experience we suggest you to use Internet Explorer 9+, Chrome, Firefox or Safari! Download Google Chrome