Treinamento integradora, Exercícios de Algoritmos. Pontifícia Universidade Católica de Minas Gerais (PUC-Minas)
Cecelso
Cecelso5 de Junho de 2015

Treinamento integradora, Exercícios de Algoritmos. Pontifícia Universidade Católica de Minas Gerais (PUC-Minas)

PDF (445.5 KB)
12 páginas
618Número de visitas
Descrição
Exercícios de concursos
20pontos
Pontos de download necessários para baixar
este documento
baixar o documento
Pré-visualização3 páginas / 12
Esta é apenas uma pré-visualização
Consulte e baixe o documento completo
Esta é apenas uma pré-visualização
Consulte e baixe o documento completo
Pré-visualização finalizada
Consulte e baixe o documento completo
Esta é apenas uma pré-visualização
Consulte e baixe o documento completo
Esta é apenas uma pré-visualização
Consulte e baixe o documento completo
Pré-visualização finalizada
Consulte e baixe o documento completo

Ano: 2009

Banca: FGV

Órgão: MEC

Prova: Analista de Sistemas

Em relação às técnicas de programação e construção de algoritmos, assinale a

alternativa que apresente corretamente duas características da estrutura de

controle repetir ... até que.

a)

O teste de controle é realizado no fim da estrutura / a saída da estrutura de repetição

ocorre quando o resultado do teste é falso.

b) As instruções no loop são executadas pelo menos uma vez / a saída da estrutura de

repetição ocorre quando o resultado do teste é falso.

c)

O teste de controle é realizado no início da estrutura / a saída da estrutura de

repetição ocorre quando o resultado do teste é verdadeiro.

d)

A execução permanece no loop enquanto o resultado do teste for falso / a saída da

estrutura de repetição ocorre quando o resultado do teste é verdadeiro.

e) A execução permanece no loop enquanto o resultado do teste for verdadeiro / a saída

da estrutura de repetição ocorre quando o resultado do teste é falso.

Ano: 2011

Banca: IADES

Órgão: PG-DF

Prova: Analista Jurídico - Analista de Sistemas

Os algoritmos são compostos por estruturas de controle de três tipos: sequencial,

condicional e de repetição. Assinale a alternativa que apresenta apenas um tipo de estrutura

de controle.

a)

...

escreva (“Digite seu nome: ”)

leia (nome)

escreva (“Digite sua idade: ”)

leia (idade)

limpe a tela

escreva (“Seu nome é:”, nome)

escreva (“Sua idade é:”, idade)

se (nome = “João”) entao

se (idade > 18) entao

escreva (nome, “ é maior de 18 anos!”)

fim se

fim se

...

b)

...

escreva (“Pressione qualquer tecla para começar...”)

leia (tecla)

mensagem ← “Não devo acordar tarde...”

numero ← 0

enquanto (numero < 100)

escreva (mensagem)

numero ← (numero + 1)

fim enquanto

escreva (“Pressione qualquer tecla para

terminar...”)

leia (tecla)

escreva (“Tecla digitada: ”)

escreva (tecla)

...

c)

...

leia (nome)

escreva (“nome digitado: ”)

escreva (nome)

se (nome = “Wally”) entao

escreva (“Encontrado o Wally!”)

senao

cont ← 5

enquanto (cont > 0)

escreva (“Não é Wally”...”)

cont ← (cont – 1)

fim enquanto

fim se

...

d)

...

var

nome: literal

num: inteiro

inicio

escreva (“Digite seu nome: ”)

leia (nome)

num ← 0

se (nome = “José”) entao

num ← (num + 1)

fim se

escreva (“Quantidade de João encontrados:

”)

escreva (num)

...

e)

...

var

nome: literal

idade: inteiro

inicio

escreva (“Digite seu nome: ”)

leia (nome)

escreva (“Digite sua idade: ”)

leia (idade)

limpe a tela

escreva (“Seu nome é:”)

escreva (nome)

escreva (“Sua idade é:”)

escreva (idade)

fim algoritmo

...

Ano: 2008

Banca: FCC

Órgão: TCE-AL

Prova: Programador

A estrutura de dados de iteração na qual uma ação será executada pelo menos uma vez,

antes da avaliação da condição, é implementada pelo comando básico

a)

condicional.

b)

faça enquanto.

c)

seqüencial.

d)

de repetição.

e)

de seleção.

Ano: 2014

Banca: FUMARC

Órgão: AL-MG

Prova: Analista de Sistemas

Em relação aos comandos em pseudocódigo correspondentes às estruturas de decisão e

repetição dos algoritmos, correlacione as colunas a seguir:

Comando (pseudocódigo) Estrutura de decisão/repetição

I. Se...então ( ) Estrutura de repetição com teste no final

II. Escolha...Caso ( ) Estrutura de seleção simples

III. Repita...Até ( ) Estrutura de repetição com variável de controle

IV. Para...Até...Faça ( ) Estrutura de seleção de múltipla escolha

A sequência CORRETA, de cima para baixo, é:

a)

II, I, III, IV.

b)

III, II, IV, I.

c)

III, I, IV, II.

d)

IV, I, III, II.

Ano: 2013

Banca: IBFC

Órgão: SEAP-DF

Prova: Professor - Informática

Apresentado, didaticamente, o código em portugol abaixo:

Seria um bom exemplo para explicar em sala de aula o conceito em programação de:

a)

estrutura seqüencial.

b)

estrutura de seleção.

c) estrutura matricial.

d)

estrutura de repetição.

Ano: 2012

Banca: FCC

Órgão: TRE-CE

Prova: Técnico Judiciário - Programação de Sistemas

Considere a estrutura de repetição seguinte:

A saída na tela será

a)

15 e 6.

b)

1 e 5.

c)

0 e 1.

d)

6 e 9.

e)

9 e 7.

Ano: 2009

Banca: FCC

Órgão: TJ-PI

Prova: Analista Judiciário - Tecnologia da Informação

Considere o trecho do algoritmo (Pseudo-Código):

Em relação às estruturas básicas de controle, o trecho de algoritmo acima refere-se a

estrutura

I. condicional simples.

II. condicional composta.

III. de repetição.

IV. de decisão ou seleção.

É correto o que consta APENAS em

a)

II, III e IV.

b)

II e IV.

c)

I e III.

d)

II e III.

e)

I, III e IV.

Ano: 2015

Banca: CETAP

Órgão: MPCM

Prova: Técnico em Informática - Desenvolvimento

No seguinte pseudocódigo, que contem uma seguinte estrutura de repetição, diga qual o

valor final da variavel X:

a)

9

b)

10

c)

11

d)

0

e)

Indefinido.

Ano: 2009

Banca: FUNIVERSA

Órgão: IPHAN

Prova: Analista - Tecnologia da Informação

Três estruturas lógicas podem compor um algoritmo: (1) Estrutura sequencial, (2) Estrutura

de seleção e (3) Estrutura de repetição. Assinale em qual dos trechos de algoritmo essas

três estruturas estão presentes, simultaneamente.

a)

b)

c)

d)

e)

comentários (0)
Até o momento nenhum comentário
Seja o primeiro a comentar!
Esta é apenas uma pré-visualização
Consulte e baixe o documento completo
Docsity is not optimized for the browser you're using. In order to have a better experience we suggest you to use Internet Explorer 9+, Chrome, Firefox or Safari! Download Google Chrome