A1 natiele gabarito, Fórmulas de Inglês
ana_ochoa
ana_ochoa

A1 natiele gabarito, Fórmulas de Inglês

PDF (413 KB)
3 páginas
2Números de download
181Número de visitas
100%de 1 votosNúmero de votos
Descrição
sdds ss
20 pontos
Pontos de download necessários para baixar
este documento
Baixar o documento
Pré-visualização3 páginas / 3
Baixar o documento
CENTRO UNIVERSITÁRIO AUGUSTO MOTTA

CENTRO UNIVERSITÁRIO AUGUSTO MOTTA

CURSO: Ciência da Computação

TURMA: VISTO DO COORDENADOR PROVA TRAB. GRAU RUBRICA DO PROFESSOR

DISCIPLINA: ALGORITMOS E PROGRAMAÇÃO AVALIAÇÃO REFERENTE: A1 A2 A3

PROFESSOR: Nathielly de Souza Campos MATRÍCULA: Nº NA ATA:

DATA: 22/04/2015 NOME DO ALUNO:

1. (Nível 1 – 2,0 pontos) Desenvolva um algoritmo que receba o salário de um funcionário, calcule e mostre o novo salário, sabendo-se que este sofreu uma redução salarial de 5%.

algoritmo "a1 exe 1"

var

sal:real

inicio

escreva ("Quanto você ganha?")

leia (sal)

escreval ("Seu novo salário é:", sal*0.95)

fimalgoritmo

2. (Nível 2 – 3,0 pontos) Faça um algoritmo que mostre o menu de opções a seguir, receba a opção do usuário e os dados necessários para executar cada operação.

Menu de Opções:

*********************************************************

1. Calcule e apresente a soma entre dois números

2. Calcule e apresente a média aritmética entre três números

Digite a opção desejada:

*********************************************************

algoritmo "a1 exe 1"

var

n1, n2, n3, n4, n5:real

op: inteiro

inicio

escreval ("*********************************************************")

escreval ("1. Calcule e apresente a soma entre dois números")

escreval ("2. Calcule e apresente a média aritmética entre três números")

escreva ("Digite a opção desejada: ")

leia (op)

escreval ("********************************************************* ")

escolha op

caso 1

escreval ("Informe dois números:")

leia (n1, n2)

escreval ("A soma dos números é: ", n1+n2)

escreval

caso 2

escreval ("Informe três números:")

leia (n3, n4, n5)

escreval ("A média aritmética dos números lidos é: ", (n3 +n4+ n5)/3)

escreval

outrocaso

escreval ("Opção Inválida!")

escreval

fimescolha

fimalgoritmo

3. (Nível 2 – 2,0 pontos) Analise o algoritmo a seguir. Em seguida, julgue os itens, marcando V para Verdadeiro e F para Falso. Vale destacar que a função randi atribui um valor aleatório entre 0 e o limite determinado

(10000) à variável n.

a) ( V ) O número fornecido pelo usuário não é armazenado na variável n. b) ( F ) O programa não usa estruturas condicionais c) ( F ) O comando da linha 18 sempre será executado d) ( V ) Na execução do programa, caso o usuário forneça o número 20000, os comandos que estão nas

linhas 10 e 11 nunca serão executados

e) ( V ) Na execução do programa, caso o usuário forneça o número 30000, o comando que está na linha 14 será executado

4. (Nível 2 – 1,0 ponto) ( Adaptada de FCC - 2012 - TST - Técnico Judiciário - Programação) Fornecidos os dados das candidatas ao time de basquete: altura, peso e idade e as restrições abaixo: altura: de 1.70 a 1.85

m | peso: de 48 a 60 kg | idade: de 15 a 20 anos. O trecho do algoritmo, em PORTUGOL, que verifica

corretamente se os dados se enquadram nas restrições fornecidas é:

a) se ((altura >= 1.70 ou altura <= 1.85) e (peso >= 48 ou peso <= 60) e (idade >= 15 ou idade <= 20)) entao

escreva (“Candidata aprovada”)

senao

escreva(“Candidata reprovada”)

fimse

b) se (1.70m < altura < 1.85m) e (48kg < peso < 60kg) e (15anos < idade < 20anos) entao escreva(“Candidata aprovada”)

senao

escreva(“Candidata reprovada”)

fimse

c) se ( 1.70 = altura = 1.85 ) e (48 = peso = 60) e (15 = idade = 20) entao escreva(“Candidata aprovada”)

senao

escreva(“Candidata reprovada”)

fimse

d) se (((altura >= 1.70) e (altura <= 1.85)) e ((peso >= 48) e (peso <= 60)) e ((idade >=15) e (idade <= 20))) entao

escreva(“Candidata aprovada”)

senao

escreva(“Candidata reprovada”)

fimse

e) se ((altura >= 1.70 e altura <= 1.85) ou (peso >= 48 e peso <= 60) ou (idade >=15 e idade <= 20)) entao

escreva(“Candidata aprovada”)

senao

escreva(“Candidata reprovada”)

fimse

5. (Nível 3 – 2,0 pontos) Leia com atenção o algoritmo a seguir e responda corretamente as questões abaixo:

a) Escreva um enunciado que resuma o algoritmo desenvolvido. Escreva um algoritmo que leia 3 números e apresente e apresente os valores lidos ordenados decrescentemente.

b) Para que serve a variável aux? Efetua a troca de valores quando uma variável é menor que a outra.

c) Se os valores digitados para a, b e c forem respectivamente 1, -8, 3 o que será impresso na linha 26? 3 1 -8

Até o momento nenhum comentário
Baixar o documento